community.egroupware.org: Community wiki

  
Community wiki
Setup Requirements

Setup Requirements


To install eGroupWare, the server should meet the following minimum system requirements:
  • Pentium III or AMD K6, 800Mhz or higher
  • 500 MB space for software installation.
  • Additional space for uploads and E-mail attachments
  • 256 MB RAM
(Note: These minimum system requirements are only a guideline. A faster processor, more memory or additional hard drive space may be neccesary.)

Additionally, eGroupWare requires the following installed software:
  • Operating System: Windows (98/ME, NT/2000/XP/Vista), Linux, Mac OS X (10.3.4 or higher)
(Note: Other operating systems may be unofficially supported.)
  • The latest official release of the eGroupWare Package
(Available from http://www.egroupware.org)
  • Webserver - Apache, IIS or other webserver that supports PHP
recommended: Apache 2; at least php 4.3, recommended: php 5.1+)
  • Database (SQL) e.g. MySQL, Postgres, MaxDB, MsSQL? ...
(Note: at least MySQL 4.1 or 5.0 (see Release Notes for 1.4))
  • SMTP server e.g. Postfix, Exim, Sendmail, Mercury ...
(Note: extended support for Postfix)
  • Web Browser - Firefox, Internet Explorer, Safari, Opera, Camino
(Note: Any standards-compliant Web browser should work
  • Client IMAP server e.g.: Cyrus, DB-Mail, Courier, Mercury (Windows)
(note: extended support for Cyrus & DB Mail)
(POP3 NOT possible)
  • Client Browser e.g. Firefox, Internet Explorer ...
(note: Firefox recommended)

Apachefriends has compiled an installer with all the necessary applications necessary to use eGroupWare, including a Webserver, database server and mailserver. Visit their Web site at http://www.apachefriends.org to download the XAMPP installer.


User Manual / Installation of eGroupWare

The user manual is written by Outdoor Unlimited Training GmbH, who also offers support together with Stylite AG, see eGroupWare support.
You are here